Back to overview
Degraded
Email verification on www.aoteaenergy.com is not working
Jul 16 at 06:30pm NZST
Affected services
Website
Resolved
Jul 18 at 10:03am NZST
Issues with email verification are resolved systems should be all operational.
Affected services
Website
Created
Jul 16 at 06:30pm NZST
This will be fixed in the coming days
Affected services
Website